Back to overview
Degraded

Room Booking Incident

Nov 13 at 10:07am GMT
Affected services
EU Web
EU API
AU Web
AU API

Resolved
Nov 13 at 11:12am GMT

​The issue affecting the booking of Microsoft Meeting Rooms through RICOH Spaces (Web, Mobile, and Smart Displays) has now been resolved.

Bookings should now be working as expected, and we’ll continue to monitor the service to ensure stability.

Created
Nov 13 at 10:07am GMT

We’re aware that booking Microsoft Meeting Rooms through RICOH Spaces (Web, Mobile, and Smart Displays) is currently not working as expected.

Our team is investigating this issue as a priority, and we’ll share another update by midday or sooner if we have further updates.

We sincerely apologise for the inconvenience and appreciate your patience while we work to restore full functionality.