Back to overview

Service Interruption

Nov 03 at 09:18am GMT
Affected services
EU Web
AU Web

Resolved
Nov 03 at 09:21am GMT

We have identified the cause of the issue and are actively working on a resolution.
Restoring full service remains our top priority, and we will provide a detailed root cause analysis once the issue is resolved.
Thank you for your continued patience while we work to restore functionality.

Created
Nov 03 at 09:18am GMT

We’re aware that certain modules — Organisation Settings, Visitors, and Jobs — are currently not loading as expected.

Our team is investigating this as a matter of urgency, and we’ll share another update later this morning.
Thank you for your patience while we work to resolve the issue.