Back to overview
Resolved

Investigating — Email notifications

Jul 28, 2026 at 1:28pm UTC
Affected services
Emails

Resolved
Jul 29, 2026 at 1:55pm UTC

Email notification delivery was fully restored across the RICOH Spaces platform at 14:38 BST.

Our third-party email provider resolved the underlying issue, and email notifications are now being delivered as expected. As the service returns to normal, you may receive some email notifications that were delayed during the incident.

We apologise for any inconvenience caused and thank you for your patience while we worked to resolve the issue.

Updated
Jul 29, 2026 at 11:09am UTC

We continue to work with our third-party email provider to restore email notification delivery across the RICOH Spaces platform. The issue remains ongoing, and our teams are actively monitoring progress.
There is no impact to platform functionality. Push notifications and in-app notifications remain unaffected.
We will provide a further update by 17:30 BST, or sooner if the service is fully restored.

Updated
Jul 29, 2026 at 9:00am UTC

We continue to work closely with our third-party email provider to restore email notification delivery across the RICOH Spaces platform.

The issue remains limited to email notifications only. Push notifications, in-app notifications, and all platform functionality continue to operate as expected.

We appreciate your patience while we work to resolve this issue and will provide a further update by 12:00 BST, or sooner if the service is fully restored.

Updated
Jul 28, 2026 at 4:30pm UTC

We are continuing to work with our third-party email provider to restore email notification delivery. Push notifications, in-app notifications, and platform access remain unaffected. We will post a further update as soon as email delivery is restored, or by 10:00 AM June 29th BST at the latest.

Created
Jul 28, 2026 at 1:28pm UTC

We are currently experiencing an issue with our third-party email delivery provider, affecting all email notifications from the platform. Push notifications, in-app notifications, and platform access are unaffected. We are working with the provider to restore email delivery and will post updates here.

The RICOH Spaces Team