Back to overview
Degraded
RICOH Spaces Platform Emails
Mar 18, 2026 at 10:11am UTC
Affected services
EU Web
Emails
Resolved
Mar 18, 2026 at 01:58pm UTC
The issue with the RICOH Spaces email has now been resolved.
Thank you for your patience and understanding
Affected services
Created
Mar 18, 2026 at 10:11am UTC
We are currently investigating reports of users not receiving RICOH Spaces email notifications. Our team is treating this as a priority and will provide further updates as soon as possible.
Affected services