Back to overview
Degraded

Service Interruption

Mar 17, 2026 at 10:15am UTC
Affected services
EU Web
EU API
AU Web
AU API

Resolved
Mar 17, 2026 at 05:40pm UTC

We are pleased to report that Platform changes were complete at 15:00 UTC and we have been seeing platform stability return. The degradation was isolated to the EU environment.

Recovery status
Our systems are currently processing a backlog of data, caused by the service degradation.

During the recovery process, you may have noticed delays with:

Meeting Room updates
Room Display Notifications
Reporting/Insight Updates

Important Note on User Accounts.

We have identified that a small number of users who attempted to login during the degradation may have had a duplicate account created. This could have temporarily effected those specific user roles and the visibility of booking data.

Our team has been actively identifying and resolving these instances. If you notice discrepancies with your account permission or booking history please contact our support team.

We appreciate your continued patience whilst we return to full normal operations.

Updated
Mar 17, 2026 at 01:38pm UTC

Following identification of the root cause, our engineering team is continuing to implement the necessary fix.

Full resolution and verification is taking longer than initially anticipated to ensure complete platform stability.

Thank you for your patience and understanding whilst we work on the resolution.

Updated
Mar 17, 2026 at 12:20pm UTC

We have identified the root cause of the performance and access issues impacting RICOH Spaces platform.

Our engineering team is working to resolve this as a priority.

We will provide our next update by 1:30 PM UTC or sooner once more information becomes available.

Thank you for your patience and understanding whilst we work on the resolution.

Created
Mar 17, 2026 at 10:15am UTC

Our team is actively investigating an issue impacting both performance and access to the RICOH Spaces platform. Please be assured this is the highest priority, and we are working towards a resolution as quickly as possible.