Back to overview
Degraded
RICOH Spaces Insights
Jun 16 at 06:57am BST
Affected services
EU Web
Resolved
Jun 16 at 09:17am BST
Access to reporting features has now been restored. The issue was resolved following collaboration with our third-party reporting provider. We sincerely appreciate your patience while we worked to resolve this.
Affected services
EU Web
Created
Jun 16 at 06:57am BST
We are currently investigating an issue where users are unable to access reporting features.
Our team is working closely with our third-party reporting provider to resolve this as quickly as possible. We appreciate your patience and will provide updates as soon as we have more information.
Affected services
EU Web