Back to overview
Degraded
RICOH Spaces Insights
Jun 09 at 09:25am BST
Affected services
EU Web
AU Web
Resolved
Jun 09 at 12:00pm BST
Access to reporting features has now been restored. The issue was resolved following collaboration with our third-party reporting provider. We sincerely appreciate your patience while we worked to resolve this.
Affected services
EU Web
AU Web
Created
Jun 09 at 09:25am BST
We are currently investigating an issue where users are unable to access reporting features.
Our team is working closely with our third-party reporting provider to resolve this as quickly as possible. We appreciate your patience and will provide updates as soon as we have more information.
Affected services
EU Web
AU Web