Back to overview
Degraded

Email Degradation

Apr 14 at 10:52am BST
Affected services
EU Web
EU API
AU Web
AU API

Resolved
Apr 14 at 02:39pm BST

Our third-party provider has confirmed that a fix has been successfully implemented, and normal service has now resumed. They will continue to closely monitor the situation to ensure ongoing stability and performance.

Created
Apr 14 at 10:52am BST

We are currently experiencing email degradation from an issue with our third-party email service provider. This may result in delays or interruptions in RICOH Spaces email delivery.

We will continue to monitor the situation closely and provide updates as they become available.

For any questions, feel free to contact the RICOH Spaces Support team.